poj4323 最短编辑距离

 

AGTC
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12240   Accepted: 4594

 

Description

Let x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:

 

  • Deletion: a letter in x is missing in y at a corresponding position.
  • Insertion: a letter in y is missing in x at a corresponding position.
  • Change: letters at corresponding positions are distinct

 

Certainly, we would like to minimize the number of all possible operations.

Illustration

 

A G T A A G T * A G G C

| | |       |   |   | |

A G T * C * T G A C G C

 

Deletion: * in the bottom line
Insertion: * in the top line
Change: when the letters at the top and bottom are distinct

This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like

 

A  G  T  A  A  G  T  A  G  G  C

|  |  |        |     |     |  |

A  G  T  C  T  G  *  A  C  G  C

 

and 4 moves would be required (3 changes and 1 deletion).

In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where n ≥ m.

Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.

Write a program that would minimize the number of possible operations to transform any string x into a string y.

Input

The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.

Output

An integer representing the minimum number of possible operations to transform any string x into a string y.

Sample Input

10 AGTCTGACGC
11 AGTAAGTAGGC

Sample Output

4

Source

这道题是典型的DP问题最短编辑距离。
其状态转移方程为
20160422105110398
#include <stdio.h>
#define MAXN 1024
int dp[MAXN][MAXN];
char str1[MAXN],str2[MAXN];
int min3(int a,int b,int c){
    int min=a;
    if(min>b) min=b;
    if(min>c) min=c;
    return min;
}
 
int main()
{
     int n,m;
      while(scanf("%d%s",&n,str1)!=EOF){
        scanf("%d%s",&m,str2);
        for(int i=0;i<=n;i++)
            dp[i][0]=i;
        for(int j=0;j<=m;j++)
            dp[0][j]=j;
            
        int count;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                str1[i-1]==str2[j-1]?count=0:count=1;
                dp[i][j]=min3(dp[i-1][j-1]+count,dp[i-1][j]+1,dp[i][j-1]+1);
            }
        }
        printf("%d\n",dp[n][m]);
    }
    return 0;
}

 

 

 

 

相关文章

显卡天梯图2024最新版,显卡是电脑进行图形处理的重要设备,...
初始化电脑时出现问题怎么办,可以使用win系统的安装介质,连...
todesk远程开机怎么设置,两台电脑要在同一局域网内,然后需...
油猴谷歌插件怎么安装,可以通过谷歌应用商店进行安装,需要...
虚拟内存这个名词想必很多人都听说过,我们在使用电脑的时候...