UVa 748 / POJ 1001 Exponentiation (浮点高精度求幂&正则表达式的应用)

748 - Exponentiation

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=97&page=show_problem&problem=689

http://poj.org/problem?id=1001

Problems involving the computation of exact values of very large magnitude and precision are common. For example,the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value ofRnwhereRis a real number (0.0 <R< 99.999) andnis an integer such that

$0 < n \le 25$

.

Input

The input will consist of a set of pairs of values for R and n . The R value will occupy columns 1 through 6,and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R n . Leading zeros and insignificant trailing zeros should be suppressed in the output.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

Description

对数值很大、精度很高的数进行高精度计算是一类十分常见的问题。比如,对国债进行计算就是属于这类问题。

现在要你解决的问题是:对一个实数R( 0.0 < R < 99.999 ),要求写程序精确计算 R 的 n 次方(R n),其中n 是整数并且 0 < n <= 25。

Input

T输入包括多组 R 和 n。 R 的值占第 1 到第 6 列,n 的值占第 8 和第 9 列。

Output

对于每组输入,要求输出一行,该行包含精确的 R 的 n 次方。输出需要去掉前导的 0 后不要的 0 。如果输出是整数,不要输出小数点。


参考资料:正则表达式30分钟入门教程


完整代码:

/*UVa: 0.242s*/
/*POJ: 125ms,3340KB*/

import java.util.*;
import java.math.*;
import java.io.*;

public class Main {
	static Scanner cin = new Scanner(new BufferedInputStream(System.in));

	public static void main(String[] args) {
		while (cin.hasNext()) {
			BigDecimal R = cin.nextBigDecimal();
			int n = cin.nextInt();
			String str = R.pow(n).stripTrailingZeros().toPlainString();
			// 返回移除所有尾部零的,不带指数字段的此BigDecimal的字符串表示形式
			if (str.indexOf("0") < str.indexOf("."))
				str = str.replaceFirst("^0*","");
				// ^匹配字符串的开始,*表示重复零次或更多次
			System.out.println(str);
		}
	}
}

Source

相关文章

jquery.validate使用攻略(表单校验) 目录 jquery.validate...
/\s+/g和/\s/g的区别 正则表达式/\s+/g...
自整理几个jquery.Validate验证正则: 1. 只能输入数字和字母...
this.optional(element)的用法 this.optional(element)是jqu...
jQuery.validate 表单动态验证 实际上jQuery.validate提供了...
自定义验证之这能输入数字(包括小数 负数 ) &lt;script ...