as easy problem

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16297    Accepted Submission(s): 10937


Problem Description
we define f(A) = 1,f(a) = ⑴,f(B) = 2,f(b) = ⑵,... f(Z) = 26,f(z) = ⑵6;
Give you a letter x and a number y,you should output the result of y+f(x).
 

Input
On the first line,contains a number T.then T lines follow,each line is a case.each case contains a letter and a number.
 

Output
for each case,you should the result of y+f(x) on a line.
 

Sample Input
6 R 1 P 2 G 3 r 1 p 2 g 3
 

Sample Output
19 18 10 ⑴7 ⑴4 ⑷
 


#include<stdio.h>

main()
{
char c;
int a,b,d,s,n,w,i,q;
scanf(%d,&q);
getchar();
//while(n--)
for(i=0;i<q;i++)
{
scanf(%c%d,&c,&s);
if(c>='A'&&c<='Z')
{a=c-'0'⑴6;
w=a+s;
//printf(%d ,w);
}
//continue;
if(c>='a'&&c<='z')
    {b=c-'0';
    b=b⑷8;
    a=-b;
   w=a+s;
   //printf(%d ,w);
//continue;
}
printf(%d ,w);
getchar();
}
  
return 0;
}

相关文章

统一支付是JSAPI/NATIVE/APP各种支付场景下生成支付订单,返...
统一支付是JSAPI/NATIVE/APP各种支付场景下生成支付订单,返...
前言 之前做了微信登录,所以总结一下微信授权登录并获取用户...
FastAdmin是我第一个接触的后台管理系统框架。FastAdmin是一...
之前公司需要一个内部的通讯软件,就叫我做一个。通讯软件嘛...
统一支付是JSAPI/NATIVE/APP各种支付场景下生成支付订单,返...