hdoj57718【Oracle】

Oracle

Time Limit: 8000/4000 MS (Java/Others)Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 738Accepted Submission(s): 322


Problem Description
There is once a king and queen,rulers of an unnamed city,who have three daughters of conspicuous beauty.

The youngest and most beautiful is Psyche,whose admirers,neglecting the proper worship of the love goddess Venus,instead pray and make offerings to her. Her father,the king,is desperate to kNow about her destiny,so he comes to the Delphi Temple to ask for an oracle.

The oracle is an integer n without leading zeroes.

To get the meaning,he needs to rearrange the digits and split the number into <b>two positive integers without leading zeroes</b>,and their sum should be as large as possible.

Help him to work out the maximum sum. It might be impossible to do that. If so,print `Uncertain`.

Input
The first line of the input contains an integer T (1T10) ,which denotes the number of test cases.

For each test case,the single line contains an integer n (1n<1010000000) .

Output
For each test case,print a positive integer or a string `Uncertain`.

Sample Input
  
  
3 112 233 1

Sample Output
  
  
22 35 Uncertain
Hint
In the first example,it is optimal to split $ 112 $ into $ 21 $ and $ 1 $,and their sum is $ 21 + 1 = 22 $. In the second example,it is optimal to split $ 233 $ into $ 2 $ and $ 33 $,and their sum is $ 2 + 33 = 35 $. In the third example,it is impossible to split single digit $ 1 $ into two parts.

Source

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<queue>
#include<list>
#include<algorithm>
#include<vector>
#include<cmath>
using namespace std;
const int maxn = 10000010;
char str[maxn];
int num[10];
int ans[maxn];
int main()
{
    int t,n;cin>>t;
    while(t--){
        scanf("%s",str);
        n=strlen(str);
        memset(num,sizeof(num));
        for(int i=0;i<n;++i){
            num[str[i]-'0']++;
        }
        if(n-num[0]<=1){
            printf("Uncertain\n");
            continue;
        }
        int cnt,x=0;
        for(int i=1;i<=9;++i){
            if(num[i]){
                cnt=i;num[i]--;break;
            }
        }
        for(int i=0;i<=9;++i){
            while(num[i]){
                if(i+cnt>=10){
                    int q=(i+cnt)%10;
                    ans[x++]=q;num[i]--;cnt=1;
                }
                else {
                    ans[x++]=i+cnt;
                    num[i]--;cnt=0;break;
                }
            }
            if(cnt==0)break;
        }if(cnt)ans[x++]=1;
        for(int i=9;i>=0;--i){
            while(num[i])printf("%d",i),num[i]--;
        }
        for(int i=x-1;i>=0;--i){
            printf("%d",ans[i]);
        }
        printf("\n");
    }
    return 0;
}

相关文章

Java Oracle 结果集是Java语言中处理数据库查询结果的一种方...
Java AES和Oracle AES是现代加密技术中最常使用的两种AES加密...
Java是一种广泛应用的编程语言,具备可靠性、安全性、跨平台...
随着移动互联网的发展,抽奖活动成为了营销活动中不可或缺的...
Java和Oracle都是在计算机领域应用非常广泛的技术,他们经常...
Java 是一门非常流行的编程语言,它可以运行于各种操作系统上...