LightOJ - 1214-Large Division(c++取模 + java的两种写法

Given two integers, a and b,you should check whether a is divisible by b or not. We kNow that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525),denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0,b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case,print the case number first. Then print ‘divisible‘ if a is divisible by b. Otherwise print ‘not divisible‘.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

代码

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
#include<stack>
#include<set>
#include<vector>
#include<map>
#include<cmath>
const int maxn=1e5+5;
typedef long long ll;
using namespace std;
char str[205];
int main()
{
   int T;
   cin>>T;
   int b;
   int cnt=1;
   while(T--)
   {
       scanf("%s",str);
       scanf("%d",&b);
       if(b<0)
       b=-b;
       int len=strlen(str);
       ll ans=0;
       for(int t=0;t<len;t++)
       {
           if(str[t]>=0&&str[t]<=9)
           {
               ans=((ans*10)+(str[t]-0))%b;
        }
        else
        {
            continue;
        }
    }
    printf("Case %d: ",cnt++);
    if(ans==0)
    {
            puts("divisible");
    }
    else
    {
        puts("not divisible");
    }
   }
   return 0;
}
import java.math.BigInteger;
import java.util.Scanner;

public class Main
{
    public static void main(String[] args) {
        Scanner sc=new Scanner(system.in);
        int T;
        int cnt=1;
        T=sc.nextInt();
        while(T>=0)
        {
        BigInteger a,b,c;
        a=sc.nextBigInteger();
        b=sc.nextBigInteger();
        a=a.abs();
        b=b.abs();
        
        System.out.print("Case "+cnt+":");
        if(a.remainder(b).equals(BigInteger.ZERO))
        {
             System.out.println(" divisible");
        }
        else
        {
            System.out.println(" not divisible");
        }
        T--;
        cnt++;
        }
       
    }

}
import java.math.BigInteger;
import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        // Todo Auto-generated method stub
        Scanner sc=new Scanner(system.in);
        int T;
        int cnt=1;
        T=sc.nextInt();
        while(T>=0)
        {
        BigInteger a,c;
  
        a=sc.nextBigInteger();
        b=sc.nextBigInteger();
        a=a.abs();
        b=b.abs();
        System.out.print("Case "+cnt+":");
     
        if(a.gcd(b).equals(b))
        {
             System.out.println(" divisible");
        }
        else
        {
            System.out.println(" not divisible");
        }
        T--;
        cnt++;
        }
       
    }

}

相关文章

本程序的编译和运行环境如下(如果有运行方面的问题欢迎在评...
水了一学期的院选修,万万没想到期末考试还有比较硬核的编程...
补充一下,先前文章末尾给出的下载链接的完整代码含有部分C&...
思路如标题所说采用模N取余法,难点是这个除法过程如何实现。...
本篇博客有更新!!!更新后效果图如下: 文章末尾的完整代码...
刚开始学习模块化程序设计时,估计大家都被形参和实参搞迷糊...