HDU 1002 A + B Problem II大数相加

Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
#include <iostream>
#include <cstring>
char s1[1007],s2[1007];
int num1[1007],num2[1007];
using namespace std;
int main()
{
    int n,e,f,c;
    cin>>n;
    int count=1;
    while(n--)
    {
        c=0;
        memset(num1,sizeof(num1));
        memset(num2,sizeof(num2));
        cin>>s1>>s2;
        int len1=strlen(s1);
        int len2=strlen(s2);
        for(int i=len1-1; i>=0; i--)
        {
            num1[c++]=s1[i]-'0';
        }
        c=0;
        for(int j=len2-1; j>=0; j--)
        {
            num2[c++]=s2[j]-'0';
        }
        for(int k=0; k<1007; k++)
        {
            num1[k]+=num2[k];
            if(num1[k]>=10)
            {
                num1[k+1]++;
                num1[k]-=10;
            }
        }
        cout<<"Case "<<count++<<":"<<endl;
        cout<<s1<<" + "<<s2<<" = ";
        for(e=1007; e>=0; e--)
            if(num1[e]!=0)
                break;
        for(f=e; f>=0; f--)
            cout<<num1[f];

        cout<<endl;
        if(n!=0)
            cout<<endl;
    }
    return 0;
}

相关文章

自1998年我国取消了福利分房的政策后,房地产市场迅速开展蓬...
文章目录获取数据查看数据结构获取数据下载数据可以直接通过...
网上商城系统MySql数据库设计
26个来源的气象数据获取代码
在进入21世纪以来,中国电信业告别了20世纪最后阶段的高速发...