HDU 1212 求大数余数

 

Big Number


Problem Description

As we kNow,Big Number is always troublesome. But it's really important in our ACM. And today,your task is to write a program to calculate A mod B.

To make the problem easier,I promise that B will be smaller than 100000.

Is it too hard? No,I work it out in 10 minutes,and my program contains less than 25 lines.
 

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000,and B will be smaller than 100000. Process to the end of file.
 

Output
For each test case,you have to ouput the result of A mod B.
 

Sample Input
  
  
2 3 12 7 152455856554521 3250
 

Sample Output
  
  
2 5 1521


...直接代码

#include <iostream>
using namespace std;
int main()
{
	char s[1111];
	int b,i;
	while(scanf("%s%d",s,&b)!=EOF)
	{
		int mod=0;
		for(i=0;i<strlen(s);i++)
		{
			mod=mod*10+s[i]-'0';
			mod%=b;
		}
		printf("%d\n",mod);
	}
	return 0;
}

相关文章

自1998年我国取消了福利分房的政策后,房地产市场迅速开展蓬...
文章目录获取数据查看数据结构获取数据下载数据可以直接通过...
网上商城系统MySql数据库设计
26个来源的气象数据获取代码
在进入21世纪以来,中国电信业告别了20世纪最后阶段的高速发...