HDU 1042 N! 阶乘大数

Problem Description
Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N!
 

Input
One N in one line,process to the end of file.
 

Output
For each N,output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2

6

代码

<pre name="code" class="java">import java.util.Scanner;
import java.math.BigInteger;  
public class Main {
	public static void main(String[] args) {
		Scanner cin= new Scanner(system.in);  //加快啥的
          int i;    
          int t;
          while(cin.hasNext()) //多重输入
          {
        	  t=cin.nextInt();    	
        	   BigInteger res=BigInteger.ONE;  
          for(i=2;i<=t;i++)
          {
        	  res=res.multiply(BigInteger.valueOf((long)i));     //将i的类型改为long 
          }
        	  System.out.println(res);
          }
	}
}
又一次证明JAVA的重要性 瞬间变水题啊 有木有。。

相关文章

自1998年我国取消了福利分房的政策后,房地产市场迅速开展蓬...
文章目录获取数据查看数据结构获取数据下载数据可以直接通过...
网上商城系统MySql数据库设计
26个来源的气象数据获取代码
在进入21世纪以来,中国电信业告别了20世纪最后阶段的高速发...