HDOJ 题目1042 N!大数

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 53495    Accepted Submission(s): 15120


Problem Description
Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N!
 

Input
One N in one line,process to the end of file.
 

Output
For each N,output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 6
 

Author
JGShining(极光炫影)
题目大意:计算大数的阶乘
要点:数组开大些,,,,,又开小了,wa了一次
ac代码
#include<stdio.h>
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int i,a[100200],c,d=1,tc,j;
		a[1]=1;
		for(i=1;i<=n;i++)
		{
			for(j=1,c=0;j<=d;j++)
			{
				tc=a[j]*i+c;
				a[j]=tc%10;
				c=tc/10;
			}
			while(c)
			{
				a[++d]=c%10;
				c/=10;
			}
		}
		for(i=d;i>=1;i--)
			printf("%d",a[i]);
		printf("\n");
	}
}

相关文章

自1998年我国取消了福利分房的政策后,房地产市场迅速开展蓬...
文章目录获取数据查看数据结构获取数据下载数据可以直接通过...
网上商城系统MySql数据库设计
26个来源的气象数据获取代码
在进入21世纪以来,中国电信业告别了20世纪最后阶段的高速发...