大数加法

A - 你会敲A+B吗?
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking varIoUs sums of those numbers. 
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment,once one became available on the third floor of the Lemon Sky apartments on Third Street.) 

Input

The input will consist of at most 100 lines of text,each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length,and will only contain digits (no VeryLongInteger will be negative). 

The final input line will contain a single zero on a line by itself. 

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670
 
   
代码张鑫提供
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
char a[1000];
int num[1000];
int main()
{
    memset(num,sizeof(num));
    int MAX=0,i;
    while(scanf("%s",a),strcmp(a,"0"))
    {
        if(strlen(a)>MAX)
        {
            MAX=strlen(a);
        }
        for(i=strlen(a)-1;i>=0;i--)
        {
            num[strlen(a)-1-i]+=a[i]-'0';
        }
        for(i=0;i<(MAX+10);i++)
        {
            if(num[i]>9)
            {
                num[i+1]+=num[i]/10;
                num[i]=num[i]%10;
            }
            else
            {
                num[i]=num[i];
            }
        }
    }
    int st;
        for(st=(MAX+10);st>=0;st--)
        {
            if(num[st]!=0)
            {
                break;
            }
        }
        if(st<0)
        {
            printf("0");
        }
        else
        {
            for(i=st;i>=0;i--)
            {
                printf("%d",num[i]);
            }
        }


        printf("\n");
    return 0;
}

相关文章

自1998年我国取消了福利分房的政策后,房地产市场迅速开展蓬...
文章目录获取数据查看数据结构获取数据下载数据可以直接通过...
网上商城系统MySql数据库设计
26个来源的气象数据获取代码
在进入21世纪以来,中国电信业告别了20世纪最后阶段的高速发...