ZOJ 3167大数乘小数的简单应用

题目链接http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3199

Find 7 Faster Than John Von Neumann
Time Limit: 1 Second Memory Limit: 32768 KB

It was said that when testing the first computer designed by von Neumann,people gave the following problem to both the legendary professor and the new computer: If the 4th digit of 2^n is 7,what is the smallest n? The machine and von Neumann began computing at the same moment,and von Neumann gave the answer first.

Now you are challenged with a similar but more complicated problem: If the K-th digit of M^n is 7,what is the smallest n?

Input

Each case is given in a line with 2 numbers: K and M (< 1,000).

Output

For each test case,please output in a line the smallest n.

You can assume:

  1. The answer always exist.
  2. The answer is no more than 100.

Sample Input

3 2
4 2
4 3

Sample Output

15
21
11
AC代码

#include <stdio.h>
#include <string.h>
int a[300],b[300];
void mul(int i){
    int j,k;
    for(j=0;j<300;j++)
        b[j]*=i;
    for(i=k=0;i<300;i++){
        j=(b[i]+k)/10;
        b[i]=(b[i]+k)%10;
        k=j;
    }
}
int main(){
    int n,k,m,i,p;
    while(~scanf("%d%d",&k,&m)){
        memset(a,sizeof(a));
        memset(b,sizeof(b));
        p=m;
        n=1;
        for(i=0;p;i++){
            a[i]=b[i]=p%10;
            p/=10;
        }
        while(a[k-1]-7){
			mul(m);
            for(i=0;i<300;i++)
                a[i]=b[i];
            n++;
        }
        printf("%d\n",n);
    }
    return 0;
}

相关文章

自1998年我国取消了福利分房的政策后,房地产市场迅速开展蓬...
文章目录获取数据查看数据结构获取数据下载数据可以直接通过...
网上商城系统MySql数据库设计
26个来源的气象数据获取代码
在进入21世纪以来,中国电信业告别了20世纪最后阶段的高速发...