hdoj 1865 1sting 【大数】【斐波那契】

1sting

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3411    Accepted Submission(s): 1318


Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’,or leave the ‘1’ there. Surly,you may get many different results. For example,given 1111,you can get 1111,121,112,211,22. Now,your work is to find the total number of result you can get.
 

Input
The first line is a number n refers to the number of test cases. Then n lines follows,each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
 

Output
The output contain n lines,each line output the number of result you can get .
 

Sample Input
  
  
3 1 11 11111
 

Sample Output
  
  
1 2 8
 

Author
z.jt


#include <stdio.h>
#include <string.h>
int s[205][200] = {0};
void table(){
    s[1][0] = 1; s[2][0] = 2;
    int i,j;
    for(i = 3; i < 205; ++ i){
        for(j = 0; j < 200; ++ j){
            s[i][j] = s[i-1][j]+s[i-2][j];
        }
        for(j = 0; j < 199; ++ j){
            if(s[i][j] > 9){
                s[i][j] -= 10;
                s[i][j+1]+=1;
            }
        }
    }
}
int main(){
    int t;
    table();
    char w[205];
    scanf("%d",&t);
    while(t --){
        scanf("%s",w);
        int len = strlen(w);
        int i = 199;
        while(i>0&&!s[len][i]) i--;
        for(; i > 0; i --) printf("%d",s[len][i]);
        printf("%d\n",s[len][0]);
    }
}

相关文章

自1998年我国取消了福利分房的政策后,房地产市场迅速开展蓬...
文章目录获取数据查看数据结构获取数据下载数据可以直接通过...
网上商城系统MySql数据库设计
26个来源的气象数据获取代码
在进入21世纪以来,中国电信业告别了20世纪最后阶段的高速发...