[HDU 2817]A sequence of numbers-大数

A sequence of numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4041    Accepted Submission(s): 1240


Problem Description
Xinlv wrote some sequences on the paper a long time ago,they might be arithmetic or geometric sequences. The numbers are not very clear Now,and only the first three numbers of each sequence are recognizable. Xinlv wants to kNow some numbers in these sequences,and he needs your help.
 

Input
The first line contains an integer N,indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence,and the last one is K,indicating that we want to kNow the K-th numbers of the sequence.

You can assume 0 < K <= 10^9,and the other three numbers are in the range [0,2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
 

Output
Output one line for each test case,that is,the K-th number module (%) 200907.
 

Sample Input
  
  
2 1 2 3 5 1 2 4 5
 

Sample Output
  
  
5 16
#include <stdio.h>
#include <string.h>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include<queue>
#include<stack>
using namespace std;
const int MOD=200907;
int main()
{
	int n;
	__int64 a,b,c,k;
    scanf("%d",&n);
    while(n--)
    {
    	scanf("%I64d %I64d %I64d %I64d",&a,&b,&c,&k);
    	if(b-a==c-b)
    	{
    		printf("%I64d\n",(a%MOD+((k-1)%MOD)*((b-a)%MOD))%MOD);
    	}
    	else
    	{
    		__int64 ans=a;
    		__int64 temp=b/a;
    		k--;
    		while(k)
    		{
    			if(k&1)	ans=ans*temp%MOD;
    			temp=temP*temp%MOD;//temP*=temp%MOD  WA 
				k>>=1; 
    		}
    		printf("%I64d\n",ans%MOD);
    	}
    }
	return 0;
}

相关文章

自1998年我国取消了福利分房的政策后,房地产市场迅速开展蓬...
文章目录获取数据查看数据结构获取数据下载数据可以直接通过...
网上商城系统MySql数据库设计
26个来源的气象数据获取代码
在进入21世纪以来,中国电信业告别了20世纪最后阶段的高速发...