HDU 1865大数

1sting
Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4020    Accepted Submission(s): 1493
Problem Description

You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’,or leave the ‘1’ there. Surly,you may get many different results. For example,given 1111,you can get 1111,121,112,211,22. Now,your work is to find the total number of result you can get.


Input

The first line is a number n refers to the number of test cases. Then n lines follows,each line has a string made up of ‘1’ . The maximum length of the sequence is 200.


Output

The output contain n lines,each line output the number of result you can get .


Sample Input

3
1
11
11111


Sample Output

1
2

8

//斐波那契数列加大数  正常的斐波那契秩只需一维数组,由于位数太多只能用二维数组来模拟
#include <stdio.h>
#include <string.h>
int str1[210][300]={{0}};
int main()
{
    int n;
    scanf("%d",&n);
    getchar();
    while(n--)
    {
        char str[300];
        gets(str);
        int len=strlen(str);
        str1[0][0]=1;
        str1[1][0]=2;
        for(int i=2;i<len;i++)
        {
            int c=0,k;
            for(k=0;k<300;k++)
            {
                int s=str1[i-1][k]+str1[i-2][k]+c;
                str1[i][k]=s%10;
                c=s/10;
            }
            while(c)
            {
                str1[i][k++]=c%10;
                c/=10;
            }
        }
        int i;
        for(i=299;i>=0;i--)  //判断是否为零
            if(str1[len-1][i])
                break;
        for(int j=i;j>=0;j--)
            printf("%d",str1[len-1][j]);
        printf("\n");
    }
    return 0;
}

相关文章

自1998年我国取消了福利分房的政策后,房地产市场迅速开展蓬...
文章目录获取数据查看数据结构获取数据下载数据可以直接通过...
网上商城系统MySql数据库设计
26个来源的气象数据获取代码
在进入21世纪以来,中国电信业告别了20世纪最后阶段的高速发...