HDOJ 1018 Big Number大数

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30893    Accepted Submission(s): 14310


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data,encryption,etc. In this problem you are given a number,you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n,which is the number of cases to be tested,followed by n lines,one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
  
  
2 10 20
 

Sample Output
  
  
7 19
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1016  1071  1061  1060  1048

这题要求n的阶乘的位数,如果n较大时,n的阶乘必将是一个 很大的数,题中说1<=n<10000000,当n=10000000时可以说n 的阶乘将是一个非常巨大的数字,对于处理大数的问题,我 们一般用字符串,这题当n取最大值时,就是一千万个数字相 乘的积,太大了,就算保存在字符串中都有一点困难,而且 一千万个数字相乘是会涉及到大数的乘法,大数的乘法是比较 耗时的,就算计算出结果一般也会超时。这让我们不得不抛弃 这种直接的方法。 再想一下,这题是要求n的阶乘的位数,而n的阶乘是n个数的 乘积,那么要是我们能把这个问题分解就好了。 在这之前,我们必须要知道一个知识,任意一个正整数a的位数 等于(int)log10(a) + 1;为什么呢?下面给大家推导一下: 对于任意一个给定的正整数a, 假设10^(x-1)<=a<10^x,那么显然a的位数为x位, 又因为 log10(10^(x-1))<=log10(a)<(log10(10^x)) 即x-1<=log10(a)<x 则(int)log10(a)=x-1,即(int)log10(a)+1=x 即a的位数是(int)log10(a)+1 我们知道了一个正整数a的位数等于(int)log10(a) + 1, 现在来求n的阶乘的位数: 假设A=n!=1*2*3*......*n,那么我们要求的就是 (int)log10(A)+1,而: log10(A) =log10(1*2*3*......n) (根据log10(a*b) = log10(a) + log10(b)有) =log10(1)+log10(2)+log10(3)+......+log10(n) 现在我们终于找到方法问题解决了,我们将求n的阶乘的位 数分解成了求n个数对10取对数的和,并且对于其中任意一个数, 都在正常的数字范围之类。 总结一下:n的阶乘的位数等于 (int)(log10(1)+log10(2)+log10(3)+......+log10(n)) + 1
 来源于:Discuss
另附链接math.h函数
注意输出时,即使是double型,也不能写成  "%.0lf\n" 格式的输出,因为有精度问题。
#include<stdio.h>
#include<math.h>
int main(){
    int n,m,i;
    double num;
    scanf("%d",&n);
    while(n--){
        scanf("%d",&m);
        num=0;
        for(i=1;i<=m;i++)
            num+=log10(i);
        printf("%d\n",(int)num+1);//不能写成printf("%.0lf\n",num+1);输入10,结果不是7而是8(错)
    }
    return 0;
}

相关文章

自1998年我国取消了福利分房的政策后,房地产市场迅速开展蓬...
文章目录获取数据查看数据结构获取数据下载数据可以直接通过...
网上商城系统MySql数据库设计
26个来源的气象数据获取代码
在进入21世纪以来,中国电信业告别了20世纪最后阶段的高速发...