HDU - 1042 - N!大数阶乘

A HDU 1042.N!(大数阶乘)

Problem Description

Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N!

Input

One N in one line,process to the end of file.

Output

For each N,output N! in one line.

Sample Input

1
2
3

Sample Output

1
2
6

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int main()
{
    int n;
    int res[70000];
    while (scanf("%d",&n)!=EOF){
        memset(res,0,sizeof(res));
        res[0] = 1;
        int j,len = 1;
        for (int i = 1; i <= n; i++){
            int c = 0;  
            for (j = 0; j < len; j++){
                res[j] = res[j]*i+c;
                if(res[j]>9){
                    c = res[j]/10;
                    res[j]%=10;
                }
                else    c = 0;
            }
            if (c){
                while(c){
                    res[j]=c%10;
                    c = c/10;
                    j++;
                    len++;
                }
            }
        }
        for(int i = len-1; i >= 0; i--)
            printf("%d",res[i]);
        printf("\n");
    }
    return 0;
}

相关文章

自1998年我国取消了福利分房的政策后,房地产市场迅速开展蓬...
文章目录获取数据查看数据结构获取数据下载数据可以直接通过...
网上商城系统MySql数据库设计
26个来源的气象数据获取代码
在进入21世纪以来,中国电信业告别了20世纪最后阶段的高速发...