poj2506 大数递推

Tiling
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8205   Accepted: 3974

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?
Here is a sample tiling of a 2x17 rectangle.


Input

Input is a sequence of lines,each line containing an integer number 0 <= n <= 250.

Output

For each line of input,output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

Source

The UofA Local 2000.10.14
#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;

int main()
{
    int a[300][200];
    memset(a,sizeof(a));
    a[0][0]=1;
    a[1][0]=1;
    a[2][0]=3;
    for(int i=3; i<=250; i++)
    {
        for(int j=0; j<=100; j++)
        {
            a[i][j]+=(a[i-1][j]+a[i-2][j]+a[i-2][j]);
            if(a[i][j]>=10)
            {
                int t=a[i][j];
                a[i][j]%=10;
                a[i][j+1]+=t/10;
            }
        }
    }
    int n;
    while(cin>>n)
    {
        if(n==0)
            cout<<1<<endl;
        else
        {
            int i=100;
            while(!a[n][i])
            {
                i--;
            }
            for(int j=i; j>=0; j--)
                cout<<a[n][j];
            cout<<endl;
        }

    }
}
/*
import java.io.*;
import java.math.BigInteger;
import java.util.*;
public class Main
{
    public static void main(String[] args)
    {
       Scanner cin = new Scanner ( system.in );
       BigInteger arr[]=new BigInteger[300];
       arr[1]=BigInteger.ONE;
        arr[0]=BigInteger.ONE;
       arr[2]=BigInteger.valueOf(3);
       arr[3]=BigInteger.valueOf(5);
       for(int i=4;i<=270;i++){
    	   arr[i]=arr[i-2].multiply(BigInteger.valueOf(2));
    	   arr[i]=arr[i].add(arr[i-1]);
       }
    	int t;
       while(cin.hasNext()==true){
    	   t=cin.nextInt();
    	   System.out.println(arr[t].toString());    	   
       }
    }
}

*/

相关文章

自1998年我国取消了福利分房的政策后,房地产市场迅速开展蓬...
文章目录获取数据查看数据结构获取数据下载数据可以直接通过...
网上商城系统MySql数据库设计
26个来源的气象数据获取代码
在进入21世纪以来,中国电信业告别了20世纪最后阶段的高速发...