杭电-2674N!Again大数阶乘

N!Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4267    Accepted Submission(s): 2279


Problem Description
WhereIsHeroFrom:             Zty,what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1,N! = N*(N-1)!
 

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
 

Output
For each case,output N! mod 2009
 

Sample Input
  
  
4 5
 

Sample Output
  
  
24 120
 


大数阶乘,但是规律是41及其以后取余2009都为0,一定要优化这一句,否则超时



#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
long long solve(long long  n)
{
	long long t=1;
	for(long long i=n;i>=2;i--)
		t=i*t%2009;
	return t;
}
int main()
{
	long long a,n,i;
	while(scanf("%lld",&n)!=EOF)
	{
		if(n>=41)
		printf("0\n");
		else
		{
			a=solve(n);
			printf("%lld\n",a);
		}
	}
	return 0;
}

相关文章

自1998年我国取消了福利分房的政策后,房地产市场迅速开展蓬...
文章目录获取数据查看数据结构获取数据下载数据可以直接通过...
网上商城系统MySql数据库设计
26个来源的气象数据获取代码
在进入21世纪以来,中国电信业告别了20世纪最后阶段的高速发...