LightOJ 1214 - Large Division 大数求余



1214 - Large Division


Time Limit:1000MS    Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Given two integers,a and b,you should check whethera is divisible by b or not. We kNow that an integera is divisible by an integer b if and only if there exists an integerc such that a = b * c.

Input

Input starts with an integer T (≤ 525),denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) andb (|b| > 0,b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case,print the case number first. Then print 'divisible' ifa is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible


题意:问b是否能整除a

思路:大数求余,注意b会爆int


ac代码

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#define MAXN 101000
#define LL long long
#define ll __int64
#define INF 0xfffffff
#define mem(x) memset(x,sizeof(x))
#define PI acos(-1)
using namespace std;
char s[MAXN];
int main()
{
	int n,i,t;
	LL b;
	int cas=0;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s%lld",s,&b);
		if(b<0)
		b=-b;
		int len=strlen(s);
		LL num=0;
		for(i=0;i<len;i++)
		{
			if(s[i]=='-')
			continue;
			num=(num*10+s[i]-'0')%b;
		}
		printf("Case %d: ",++cas);
		if(num==0)
		printf("divisible\n");
		else
		printf("not divisible\n");
	}
	return 0;
}

相关文章

自1998年我国取消了福利分房的政策后,房地产市场迅速开展蓬...
文章目录获取数据查看数据结构获取数据下载数据可以直接通过...
网上商城系统MySql数据库设计
26个来源的气象数据获取代码
在进入21世纪以来,中国电信业告别了20世纪最后阶段的高速发...