1118 Birds in Forest 25 分)

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest,and for any pair of birds,tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case,the first line contains a positive number N (10?4??) which is the number of pictures. Then N lines follow,each describes a picture in the format:

B?1?? B?2?? ... B?K??

where K is the number of birds in this picture,and B?i??‘s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 10?4??.

After the pictures there is a positive number Q (10?4??) which is the number of queries. Then Q lines follow,each contains the indices of two birds.

Output Specification:

For each test case,first output in a line the maximum possible number of trees and the number of birds. Then for each query,print in a line Yes if the two birds belong to the same tree,or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No
 
#include <bits/stdc++.h>
using namespace std;
int p[10010];
int visit[10010];
int a[10010];
int n,m,k;
int found(int a)
{
    if(a==p[a]){
        return a;
    }
    return p[a]=found(p[a]);
}
void unite(int a,int b)
{
    int x = found(a);
    int y = found(b);
    if(x!=y){
        p[x] = y;
    }
    return ;
}
bool istrue(int a,int b){
    return found(a) == found(b);
}
int main()
{
    int x,y;
    set<int> s;

    for(int i=1;i<=10010;i++){
        p[i] = i;
    }
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%d",&m);
        for(int j=1;j<=m;j++)
        {
            scanf("%d",&a[j]);
            s.insert(a[j]);
        }
        for(int j=2;j<=m;j++)
        {
            unite(a[j-1],a[j]);
        }
    }
    int sum = s.size();
    set<int> ss;
    for(int i=1;i<=sum;i++)
    {
        ss.insert(found(i));
    }
    cout<<ss.size()<<" "<<sum<<endl;
    scanf("%d",&k);
    while(k--)
    {
        scanf("%d%d",&x,&y);
        if(istrue(x,y)){
            cout<<"Yes"<<endl;
        }else{
            cout<<"No"<<endl;
        }
    }
    return 0;
}

相关文章

自1998年我国取消了福利分房的政策后,房地产市场迅速开展蓬...
文章目录获取数据查看数据结构获取数据下载数据可以直接通过...
网上商城系统MySql数据库设计
26个来源的气象数据获取代码
在进入21世纪以来,中国电信业告别了20世纪最后阶段的高速发...